Ticket #269 (closed enhancement: fixed)

Opened 5 years ago

Last modified 5 years ago

Migrate from libglade to GtkBuilder

Reported by: andre Owned by: lennart
Milestone: Avahi 0.6.26 Component: other
Keywords: Cc:

Description

Avahi-0.6.25 depends on libglade: ./configure.ac: PKG_CHECK_MODULES(GLADE20, [ libglade-2.0 >= 2.4.0 ])

In GNOME 2.27, libglade has been deprecated in favor of GtkBuilder?. See  http://library.gnome.org/devel/gtk/stable/gtk-migrating-GtkBuilder.html for migration instructions. Also see  http://live.gnome.org/GnomeGoals/RemoveLibGladeUseGtkBuilder

Attachments

0001-Replace-libglade-with-GtkBuilder.patch Download (24.7 KB) - added by robert.ancell 5 years ago.
Replace libglade with GtkBuilder?

Change History

Changed 5 years ago by robert.ancell

Replace libglade with GtkBuilder?

Changed 5 years ago by robert.ancell

ping

Changed 5 years ago by lennart

The patch is incomplete, the .ui files are missing?

Changed 5 years ago by lennart

  • status changed from new to closed
  • resolution set to fixed
  • milestone set to Avahi 0.6.26

Merged with minor modifications, including the addition of the missing .ui file.

Note: See TracTickets for help on using tickets.